The Long Delay at Time Warner
Posted in Tech
Afternoon watch, 6 bells (3:16 pm)

For the past few weeks I've been working on a strange issue from my Time Warner cable connection at home. There were two symptoms: a long delay of roughly 30 seconds when trying to open a web page on my company's webserver, and a similar delay when connecting to my office via secure shell (ssh).

I soon found out that some of my coworkers see the same problem, but only those that have Time Warner cable at home—but not all of those that have Time Warner see the long delay.

Many theories were thrown out about what was happening: a DNS issue, a firewall, some kind of faulty caching proxy server, etc., most of which were ruled out because we didn't see the same problem from all locations and that I could reproduce the problem on two separate servers. Watching the webserver's logfile showed no entries for the 30 seconds I waited and then all of a sudden the log was populated and my page loaded quickly.

Examining the differences between the clients with and without the problem, I noticed that those that behaved as expected had working reverse-DNS entries, while those that had trouble returned an error when I queried for their reverse DNS address.

So as a test, I disabled reverse-DNS on my SSH server at my office and BAM—the delay was gone!

Continuing the experiment, I added a record for my home IP address on my server's /etc/hosts file. Just like that, I was loading pages at full speed with no delays.

When I query for a reverse-DNS resolution of my home IP address, Time Warner's server returns an error. Contacting them to have them fix their broken DNS server has been an awful experience, starting with "Let's reboot your router first."

Since I expect this to never be resolved, and since I run my own DNS servers anyway, I started adding in-addr.arpa zones for the broken ranges of DHCP addresses. While this will work for me, it's a hack at best and I would rather get the issue fixed. Unfortunately it's out of my hands.

So Time Warner, surprise me. Fix it up, or un-configure the range of addresses even! Don't just leave it broken.

Leave a Comment »